3 层采用是指通过 UniFi Network 网络应用程序对 UniFi 设备进行远程采用的过程。

你可以使用位于云服务器上(例如阿里云或 Amazon EC2 )或 NOC 上的应用程序进行 3 层采用。

有关常规设备采用,请参阅 UniFi - 设备采用


概述


在许多部署实例中,无法让 UniFi Network 网络应用程序在内部架设运行,但是您可以在云端或者 NOC 中运行该程序。例如,对于具有许多设备的大型项目,您可以使用以下几种方法进行设备采用:

  • 将笔记本电脑连接到设备的局域网内,通过 Chrome 浏览器执行采用(最简单的方法)。
  • 当您已连接到该局域网,打开浏览器并跳转到云端页面:UniFi 远程访问门户或 UniFi Network 网络应用程序(使用云时启动)。
  • 在 Amazon EC2 上创建一个虚拟应用程序。
  • 配置 DHCP 服务器或 DNS 服务器。

初始设置


在尝试 L3(远程)采用之前,请确保您熟悉 UniFi 设备常规 L2 采用工作原理(设备需与 UniFi Network 网络应用程序在同一网络上)。另外,为了成功采用设备,您需满足以下条件,可以访问互联网,并能通过内部网络(本地)访问路由器。

  1. WAN口连接互联网。
  2. LAN 口进行本地连接,用于访问路由器(USG 或第三方设备)上的管理功能。

UniFi AP 有默认的通知 URL http://unifi:8080/inform。 因此,使用 DHCP option 43 或 DNS 的目的是让 AP 知道 UniFi Network 网络应用程序主机的 IP。

如果您遇到设备发现问题,请参阅 UniFi - 设备采用故障排除

在运行 Chrome 浏览器的计算机上安装发现工具插件(可在 Chrome 网上应用商店 免费获得)后,任何本地可用的非正在管 UniFi 设备(即与您的计算机在相同的二层网络中)将在 UniFi Cloud 云访问门户 以及你的 UniFi Network 网络应用本身中显示为 “待采用”(在设备页面显示)。要远程访问该应用程序,可参考启用远程访问

通过 UniFi OS 进行采用

1.访问 https://unifi.ui.com 并使用您的 Ubiquiti SSO 凭据登录。 2.导航到 设备(Devices) 部分。 3.要采用的设备将显示为 准备采用(ready to be adopted)。 单击 采用(Adopt)

1.png

通过 UniFi 远程访问门户

1.访问 https://network.unifi.ui.com/ 并使用您的 Ubiquiti SSO 凭据登录。 2.转到 设备(Devices) 部分,找到处于 待采用(Pending Adoption) 状态的设备,单击 采用(ADOPT)

2.png

3.在弹出的采用窗口中,选择 UniFi Network 网络主机和将采用该设备的站点(如果此主机有多站点),然后单击 采用(Adopt)

3.png

通过 UniFi Network 网络应用程序采用

1.启动 UniFi Network 网络,进入 设备(Devices) 部分,找到状态为 “待采用” 的设备,点击 采用(Adopt )

4.png


高级 3 层采用方法


DNS

您需要配置 DNS 服务器,将“unifi”解析为 UniFi 网络主机的 IP 地址,确保设备可以 解析 UniFi Network 网络域名。例如,如果你设置为 http://XYZ:8080/inform , 那么从设备上 ping,以确定 XYZ 是否可解析/可到达。或者你也可以使用 FQDN 为应用程序通知 URL:http://FQDN:8080/inform

故障排除:设备(使用静态 IP)无法连接到 L3 UniFi Network 网络应用程序

  • 在 UniFi Network 网络应用程序中将设备从 DHCP 配置为静态时,请确保您已输入 DNS 的 IP。 如果不是,则设备无法联系 DNS 解析 UniFi Network 网络的域名。
  • 如果设备已重置,请确保您已“通知”设备 两次(使用发现应用程序,按两次 inform 按钮)UniFi Network 网络应用程序的地址。 请参阅上一步骤。

DHCP Option 43

如果使用 Ubiquiti 的 EdgeMAX 路由器,则只需在 DHCP 服务器上的“unifi”字段中输入 UniFi Network 网络主机的 IP 地址,即可完成 DHCP Option 43。

注意: 在 WAN 接口上获得 DHCP 租约时,UniFi 安全网关 (USG) 不会使用 DHCP option 43 添加 UniFi Network 网络应用程序地址。

要使用 DHCP option 43,您需要配置 DHCP 服务器。 我们在下面提供了一些第三方示例,但请参阅提供商的支持文档以获取最新说明。 例如:

Linux ISC DHCP 服务器:dhcpd.conf

# ...
option space ubnt;
option ubnt.unifi-address code 1 = ip-address;

class "ubnt" {
        match if substring (option vendor-class-identifier, 0, 4) = "ubnt";
        option vendor-class-identifier "ubnt";
        vendor-option-space ubnt;
}

subnet 10.10.10.0 netmask 255.255.255.0 {
        range 10.10.10.100 10.10.10.160;
        option ubnt.unifi-address 201.10.7.31;  ### UniFi Network host IP ###
        option routers 10.10.10.2;
        option broadcast-address 10.10.10.255;
        option domain-name-servers 168.95.1.1, 8.8.8.8;
        # ...
}

Cisco CLI

# assuming your UniFi is at 192.168.3.10
ip dhcp pool <pool name>
network <ip network> <netmask>
default-router <default-router IP address>
dns-server <dns server IP address>
option 43 hex 0104C0A8030A # 192.168.3.10 -> CO A8 03 0A

# Why 0104C0A8030A ?
#
# 01: suboption
# 04: length of the payload (must be 4)
# C0A8030A: 192.168.3.10

Mikrotik CLI

/ip dhcp-server option add code=43 name=unifi value=0x0104C0A8030A
/ip dhcp-server network set 0 dhcp-option=unifi

# Why 0104C0A8030A ?
#
# 01: suboption
# 04: length of the payload (must be 4)
# C0A8030A: 192.168.3.10
用户提示: 用户须知和提示部分参阅更多 DHCP Option 43 说明。

SSH

如果您可以通过 SSH 连接到设备,则可以通过 CLI 命令进行 L3 采用:

  1. 确保设备已升级至最新版本固件。 请参阅 UniFi Network 网络 - 设备和应用程序更新的高级选项
  2. 确保设备处于出厂默认状态。 如果不是,请运行以下命令:
sudo syswrapper.sh restore-default
  1. 通过 SSH 连接设备,输入以下内容并点击回车,用 UniFi Network 网络应用的主机 IP 地址代替 “ip-of-host”:
set-inform http://ip-of-host:8080/inform
  1. 发出设置通知后,UniFi 设备将显示在 UniFi Network 网络的设备部分以供采用。 单击 采用(Adopt) 后,设备将显示为离线或处于“采用中”状态,然后显示为“同步中”和“已连接”。

用户须知和提示


Windows 服务器 DHCP Option 43

用户提示: 如果是 Windows 服务器,请参阅此站外博客文章

将 PFSense 与 DHCP Option 43 一起使用

注意:与我们所有的示例一样,我们使用的是示例 IP 地址,您可以输入自己的 IP 地址。

  1. https://www.browserling.com/tools/ip-to-hex 中输入您的 IP

5.png

  1. 单击转换为十六进制(Convert to Hex)!

6.png

  1. 将 01:04 添加到转换后的 IP 开头,所以它看起来像这样:

01:04:ac:10:21:04

  1. 将其 插入值(Value) 字段。

7.png

将 Palo Alto 网络与 DHCP Option 43 (Pan OS 7.1) 一起使用

8.png


相关文章