EdgeSwitch - 配置 VLAN ACL

一.实验目的:
 
在同一个交换机上建立 vlan2/3/4,利用 VLAN ACL 限制 vlan2 的网段不能访问 vlan3 的网段,而其他网段可以互相访问。
 
二.EdgeSwitch 基础配置
1.用户可选择通过 console 线或网线 telnet 访问连接 EdgeSwitch,并输入账号 ubnt 密码 ubnt 登入
2.建立 3 个 vlan 即 vlan2/vlan3/vlan4
 
enable

vlan database

vlan 2

vlan routing 2

vlan 3

vlan routing 3

vlan 4

vlan routing 4

end
 
3.建立 3 个虚拟接口并配置接口 IP 地址
 
configure

interface vlan 2

ip address 192.168.2.1 255.255.255.0

interface vlan 3

ip address 192.168.3.1 255.255.255.0

interface vlan 4

ip address 192.168.4.1 255.255.255.0

end
 
4.划分接口到对应 vlan 并配置对应 pvid
(1)划分接口 5-6 属于 vlan2 并配置 pvid 为 2
 
configure

interface 0/5-0/6

vlan pvid 2

vlan participation exclude 1

vlan participation include 2

(2)划分接口 7-8 属于 vlan3 并配置 pvid 为 3

 
interface 0/7-0/8

vlan pvid 3

vlan participation exclude 1

vlan participation include 3
 
(3)划分接口 9-10 属于 vlan4 并配置 pvid 为 4
 
interface 0/9-0/10

vlan pvid 4

vlan participation exclude 1

vlan participation include 4

end
 

5.开启 vlan 之间路由互通

configure

ip routing
 

三.EdgeSwitch ACL 配置
1.配置 IP access-list,拒绝源 192.168.2.0/24 访问 192.168.3.0/24,而允许其他网段互相访问

ip access-list ip123

deny ip 192.168.2.0 0.0.0.255 192.168.3.0 0.0.0.255

permit ip any any
 

2.配置 IP access-group vlan 接口及方向

ip access-group ip123 vlan 2 in
 

3.保存所有配置

end

write memory

y